[update] vorrei aggiornarmi…{0}

aruba

… nel senso che mi è venuta un po’ di voglia di tornare a bloggare qualche minchiata ogni tanto, e mi piacerebbe quindi aggiornare wordpress, che adesso sta alla versione 3.2.1. il blog del keiserciccio viaggia ancora alla 2.7 e rotti, figuratevi voi. per dire, un bel plugin di twitter che ho trovato non funziona con questo vecchiume.

peccato che NON possa aggiornare wordpress all’ultima versione disponibile. perché? perché aruba gira con versioni di mysql e php talmente vecchie da far spavento. roba che non ci posso mettere neppure wordpress 3.0. e sì che sono versioni rilasciate da MESI. cosa diavolo aspettano? il prossimo incendio? -_-’

alternative? un altro hosting?

[update] dopo un po’ di smanacciamenti e ricerche in rete ho scoperto che aruba permette di selezionare la versione di php attualmente in uso (entrando in un nascostissimo pannello di controllo), e ho quindi subito attivato l’ultima disponibile. peccato che non permetta di fare lo stesso anche con mysql. in compenso, cambiando versione di php erano comparse in cima alla pagina righe di errore che riportavano quanto fossero deprecate alcune chiamate utilizzate dalla versione obsoleta di wordpress. -_-’
per poter sperare in un upgrade di mysql ho aperto un ticket con l’assistenza, anche se non sono particolarmente ottimista: in giro ho letto che la versione di mysql installata sui domini sgrausi come il mio è vincolata a ciò che gira sotto una determinata macchina, e se per chissà quale applicazione critica non può essere aggiornata, tocca tenersi quella e bon. quindi, o quelli di aruba sono simpatici e mi migrano, oppure mi ciuccio il mio mysql vecchissimo.
per risolvere il problema delle righe di errore in cima a ogni pagina ho rimesso anche la versione vecchia di php. evviva!

Argomenti correlati: